Fluid Particles overtop Inlet buffer zone

Hello everyone,

I am experienced this problem of fluid particles overtopping the inlet buffer zone.

My inlet conditions are:


        <memoryresize size0="2.0" size="4.0" comment="Initial memory resize (size0) and the following memory resizes according to initial inlet/outlet particles (default=2 and 4)" />

        <determlimit value="1e+3" comment="Use 1e-3 for first_order or 1e+3 for zeroth_order (default=1e+3)" />


          <refilling value="0" comment="Refilling mode. 0:Simple full, 1:Simple below zsurf, 2:Advanced for reverse flows (very slow) (default=1)" />

          <inputtreatment value="2" comment="Treatment of fluid entering the zone. 0:No changes, 1:Convert fluid (necessary for outlet), 2:Remove fluid (recommended for inlet)" />

          <layers value="8" comment="Number of inlet/outlet particle layers" />

          <zone2d comment="Input zone for 2D simulations">

            <particles mkfluid="1" direction="right" />


          <imposevelocity mode="0" comment="Imposed velocity 0:fixed value, 1:variable value, 2:Extrapolated value (default=0)">

            <velocity v="0.08333" comment="Uniform velocity" units_comment="m/s" />


          <imposerhop mode="1" comment="Outlet rhop 0:Imposed fixed value, 1:Hydrostatic, 2:Extrapolated from ghost nodes (default=0)" />

          <imposezsurf mode="2" comment="Inlet Z-surface 0:Imposed fixed value, 1:Imposed variable value, 2:Calculated from fluid domain (default=0)">

            <zsurf value="0.21" comment="Characteristic inlet Z-surface (used for Hydrostatic option)" units_comment="m" />




Ant Initial conditions for the fluid is Vinitial=Vinlet.

Can someone help me with this issue ?


  • Dear user

    First, check the XML examples in \examples\inletoutlet, which are closer to what you are planning to simulate.

    Then, note that inlet initial creation is usually with a higher column of particles than the fluid domain.

    In any case, @jmdalonso and @taffo may help here.

  • Dear Alex

    Thank you for your response.

Sign In or Register to comment.