Chrono Restart Issues


I am running a simulation using Chrono (collision + linear spring). As with the latest update, we are able to restart simulations using Chrono.

Initially, I restarted my simulation after the first time step and was successfully able to restart it. I ran a new simulation for 48 hours. It was stopped after 48 hours due to job runtime limitations with around 326 timesteps.

When i tried restarting with timestep 326, I am encountering the following error

I looked at the ErrorBoundaryOut file - it contains no data

export name=IrregularWaveTestA1

export dirout=${name}_out

export diroutdata=${dirout}/data

# "executables" are renamed and called from their directory

export dirbin=..../bin/linux


export gencase="${dirbin}/GenCase_linux64"

export dualsphysicscpu="${dirbin}/DualSPHysics5.0CPU_linux64"

export dualsphysicsgpu="${dirbin}/DualSPHysics5.0_linux64"

export boundaryvtk="${dirbin}/BoundaryVTK_linux64"

export partvtk="${dirbin}/PartVTK_linux64"

export partvtkout="${dirbin}/PartVTKOut_linux64"

export measuretool="${dirbin}/MeasureTool_linux64"

export computeforces="${dirbin}/ComputeForces_linux64"

export isosurface="${dirbin}/IsoSurface_linux64"

export flowtool="${dirbin}/FlowTool_linux64"

export floatinginfo="${dirbin}/FloatingInfo_linux64"

export olddiroutdata=${diroutdata}

export dirout=${name}_Part2_out

export diroutdata=${dirout}/data

${gencase} ${name}_Def ${dirout}/${name} -save:all

if [ $? -ne 0 ] ; then fail; fi


## Executes DualSPHysics to simulate SPH method.

${dualsphysicsgpu} -gpu ${dirout}/${name} ${dirout} -dirdataout data -svres -restartchrono:1 -partbegin:0325 ${olddiroutdata}

if [ $? -ne 0 ] ; then fail; fi

This is my Linux Job File used for restarting. If you could let me know what issue could be the reason, I can restart my simulation


  • I believe the issue would be the third warning, that it is not fully supported yet. Perhaps what happened was that when it tried to re-initialize from the latest time step, somewhere in the code it mistakenly ended up dividing by zero and producing nan results.

    Nan results are of course out of bounds and breaks the restart.

    This is just me theorizing, I haven't played with the latest update yet, waiting for the new release next year hopefully! :-)

    I hope you are able to get it working!

    Kind regards

Sign In or Register to comment.