No particle creation with inout and linux docker

Hello,

I've been running simulation under widows and the same simulation using a dockerfile based on nvidia/cuda:9.2-base-ubuntu18.04 image.

I've got a water inlet (under execution/special/inout) in my def xml that is working fine under windows. But with my docker, no particle is ever created. Apart from that, the simulation is running without error.

I have not seen trace of inout problems with linux in this forum so maybe this comes from the misuse of my GPU from a docker ?

Comments

  • Hello,

    I'm still struggling with this issue.

    My env where the simu is working fine is windows 11. First particles are created at step 9. The beginning of simulation in the Run.out is :

    PART      PartTime     TotalSteps   Steps   Time/Sec  Finish time       
    ========= ============ ============ ======= ========= ===================
    Part_0001     0.040055          316     316     28.03 07-11-2022 09:59:11
    Part_0002     0.080121          632     316     30.27 07-11-2022 09:59:13
    **CellDiv: Requested gpu memory for 12950 cells (CellMode=Full): 0.2 MB.
    Part_0003     0.120114          957     325     30.70 07-11-2022 09:59:14
    Part_0004     0.160039         1310     353     32.03 07-11-2022 09:59:16
    **CellDiv: Requested gpu memory for 15390 cells (CellMode=Full): 0.2 MB.
    Part_0005     0.200006         1934     624     56.11 07-11-2022 09:59:26
    Part_0006     0.240030         2641     707     64.65 07-11-2022 09:59:35
    **CellDiv: Requested gpu memory for 17670 cells (CellMode=Full): 0.3 MB.
    Part_0007     0.280012         3235     594     54.73 07-11-2022 09:59:40
    Part_0008     0.320081         3765     530     50.35 07-11-2022 09:59:42
    Part_0009     0.360006         4234     469     44.81 07-11-2022 09:59:42
     Particles new: 1736 (total new: 8680) - Current np: 596948
    **CellDiv: Requested gpu memory for 20520 cells (CellMode=Full): 0.3 MB.
    Part_0010     0.400038         4677     443     42.85 07-11-2022 09:59:42
    Part_0011     0.440084         5137     460     46.20 07-11-2022 09:59:43
    **CellDiv: Requested gpu memory for 23310 cells (CellMode=Full): 0.4 MB.
    Part_0012     0.480044         5547     410     40.87 07-11-2022 09:59:43
    Part_0013     0.520048         5925     378     36.69 07-11-2022 09:59:41
    **CellDiv: Requested gpu memory for 26640 cells (CellMode=Full): 0.4 MB.
    Part_0014     0.560026         6351     426     41.79 07-11-2022 09:59:41
    Part_0015     0.600001         6744     393     37.32 07-11-2022 09:59:40
     Particles new: 1736 (total new: 10416) - Current np: 598578
     Particles out: 106 (total out: 106)
    

    I'm also running the simu on a docker based on image  nvidia/cuda:9.2-base-ubuntu18.04 and it gives :

    PART       PartTime      TotalSteps    Steps    Time/Sec   Finish time        
    =========  ============  ============  =======  =========  ===================
    Part_0001      0.040055           316      316      55.97  02-11-2022 17:12:09
    Part_0002      0.080121           632      316      46.20  02-11-2022 17:11:19
    **CellDiv: Requested gpu memory for 12950 cells (CellMode=Full): 0.2 MB.
    Part_0003      0.120114           957      325      45.29  02-11-2022 17:11:00
    Part_0004      0.160039          1310      353      46.96  02-11-2022 17:10:55
    **CellDiv: Requested gpu memory for 15390 cells (CellMode=Full): 0.2 MB.
    Part_0005      0.200006          1934      624      83.42  02-11-2022 17:12:04
    Part_0006      0.240030          2641      707      87.82  02-11-2022 17:12:58
    **CellDiv: Requested gpu memory for 17670 cells (CellMode=Full): 0.3 MB.
    Part_0007      0.280012          3235      594      77.59  02-11-2022 17:13:22
    Part_0008      0.320081          3765      530      80.29  02-11-2022 17:13:43
    Part_0009      0.360006          4234      469      65.74  02-11-2022 17:13:44
    **CellDiv: Requested gpu memory for 20520 cells (CellMode=Full): 0.3 MB.
    Part_0010      0.400038          4677      443      60.78  02-11-2022 17:13:39
    Part_0011      0.440084          5137      460      68.00  02-11-2022 17:13:42
    **CellDiv: Requested gpu memory for 23310 cells (CellMode=Full): 0.4 MB.
    Part_0012      0.480044          5547      410      54.95  02-11-2022 17:13:33
    Part_0013      0.520063          5925      378      48.23  02-11-2022 17:13:20
    **CellDiv: Requested gpu memory for 26640 cells (CellMode=Full): 0.4 MB.
    Part_0014      0.560090          6353      428      61.17  02-11-2022 17:13:20
      Particles out: 6  (total out: 6)  -  Current np: 595206
    Part_0015      0.600087          6746      393      56.19  02-11-2022 17:13:15
      Particles out: 4  (total out: 10)  -  Current np: 595202
    **CellDiv: Requested gpu memory for 29970 cells (CellMode=Full): 0.5 MB.
    

    No new particles :-( If I run the simulation in docker but in cpu mode, the problem is still there.

    Any clue why this is happening ?

Sign In or Register to comment.