mDBC - excluded particle error

edited June 13 in DualSPHysics v5.0

Hello everyone,

I'm trying to run a complex geometry with mDBC and i'm getting this error:

-------------------------------------------------------

*** ERROR: Some boundary particle was excluded. ***

TimeStep: 0.000000 (Nstep: 0)

Total boundary: 17540 (fixed=0 moving=17540 floating=0)

Excluded for: position=17540 rhop=0 velocity=0

*** Exception (JSphGpuSingle::AbortBoundOut) at ..\source\JSph.cpp:2472

Text: Fixed, moving or floating particles were excluded. Check VTK file Error_BoundaryOut.vtk with excluded particles.

-------------------------------------------------------

Nothing really new as an error. I thought I could fix that easily.

Trying to understand what I was doing wrong, I opened the Error_BoundaryOut.vtk in Paraview,, but not even a particle was shown. I tried to enlarge my domain by a lot, adding a few far points in the simulation.

But I'm still having the same error. Do some of you have any clue about what could be happening?


Best regards

Comments

  • Probably getting NaN values since the motion is too powerful.

    Kind regards

  • edited June 15

    I found the problem. The .stl files were too large (above 20 Mb).

    Thank you for the advise, anyway!

    Best regards

    Edit: I spoke too early; actually it seems that was not the real problem, I will tell when I will solve it.

  • Yes, the error does not mention size

    It is because the motion is doing something unexpected or that your simulation domain is way too small. Try adding +100% in all fields at the bottom of XML.

    Kind regards

Sign In or Register to comment.