DATASET type invalid

I am attempting to use the drawfilevtk feature in the case_def.XML file, but am getting either DATASET type invalid or DataFile version invalid exceptions.

I get DataFile version invalid if I use a .vtk file that is version 2.0, which turns to a DATASET type invalid if I use a version 3.0 .vtk file.

What do I need to do to get my .vtk files to be valid?


  • Can you open those .vtk files in Paraview without problem?

    If yes, then expert them from Paraview as .vtk and use those new ones


  • @nick_p I have had the same issue. What worked for me was downloading an older version of Paraview and rexporting the file using this. Paraview 4.2 worked for me I believe.

    Kind regards

  • @Alex I can open them in paraview, i tried exporting both as a .vkt ascii and .vtk bianry but neither worked.

    @Asalih3d I will try using a different version of paraview and let you know what happens. Thank you.

  • @Asalih3d Thank you, using Paraview 4.2.0 worked flawlessly.

    For anyone who who sees this in the future, in Paraview 4.2.0, save data, select legacy vtk, an option will ask if you want to use binary or ASCII, binary worked for me.

    once again,

    Thank you.

  • No problem Nick! I believe it also took me a while testing out different version to get it to work the first time I encountered the issue. Good that you posted the step by step for future questions

    Kind regards

Sign In or Register to comment.