Why free slip mode is not allows

I am running the sloshing tank example in mDBC folder. in xml file, I add two important lines:


<parameter key="Boundary" value="2" comment="Boundary method 1:DBC, 2:mDBC (default=1)" />

 <parameter key="SlipMode" value="3" comment="Slip mode for mDBC 1:DBC vel=0, 2:No-slip, 3:Free slip" />

Then in the batch file, I enter the following line:

%dualsphysicscpu% -mdbc_freeslip %dirout%/%name% %dirout% -dirdataout data -svres

However, when I run the simulation, the error reads:

*** Exception (JSphCpuSingle::LoadConfigCommands) at ..\source\JSph.cpp:775

Text: Only the slip mode velocity=0 is allowed with mDBC conditions.

I wonder why "only v=0 is allowed in mDBC"? Since in both the documentation and the help files, it looks like there are 3 mDBC choices.



  • We are still working on a robust implementation to interpolate velocity in the ghost nodes for 3-D complex geometries.

    So that only the option of v=0 works now with mDBC in v5.0


Sign In or Register to comment.