AWAS Deepwater Bug?

Dear developers,

While AWAS for piston type wave maker in shallow water works perfectly for me, it does not work for deep water case. After 3/4 wave cycles, the piston keeps moving forward. Any explanations? How to resolve this? I'm using V5.0/2D simulation.


  • You need to provide more information, especially plots would be helpful.

    1. What does your case look like?
    2. What are your settings for awas configuration of piston? Seems like you have some wrong ramp settings
    3. Have you tried looking at the examples to see how they are doing?

    Kind regards

  • Dear Sam,

    first of all you must consider that employing a piston for deep-water is the least accurate that you can use. The orbital velocity profile for waves in deep water is very difference from the one generated at the board interface. Piston wavemakers are not used or should not be used in the experimental facilities either for deep water conditions.

    Moreover, you should share with us your settings. If piston keeps moving, means that is not reading the right information for applying AWAS.



  • samsam
    edited September 14

    Hi Asalih3d and Corrado,

    I know piston type wave maker is not for deep water, but this is the only type that supports AWAS at the moment. I am trying to model a 2D regular wave of 6m height and 72m long. Here are my AWAS settings. My guess is the drift correction configuration is probably not right. I would appreciate any suggestions.

    awas_zsurf %Active Wave Absorption

                startawas value="20" comment="Time to start AWAS correction (def=ramp*waveperiod)"

                swl value="36.153" comment="Still water level (free-surface water)"

                elevation value="2" comment="Order wave to calculate elevation 1:1st order, 2:2nd order (def=2)"

                gaugex valueh="4" comment="Position in X from piston to measure free-surface water (def=5*Dp)"

                gaugey value="0" comment="Position in Y to measure free-surface water"

                gaugezmin value="30" comment="Minimum position in Z to measure free-surface water, it must be in water (def=domain limits)"

                gaugezmax value="42" comment="Maximum position in Z to measure free-surface water (def=domain limits)"

                gaugedp value="0.25" comment="Resolution to measure free-surface water, it uses Dp*gaugedp (def=0.1)"

                coefmasslimit value="0.4" comment="Coefficient to calculate mass of free-surface (def=0.5 on 3D and 0.4 on 2D)"

                savedata value="1" comment="Saves CSV with information 1:by part, 2:more info 3:by step (def=0)"

                limitace value="2" comment="Factor to limit maximum value of acceleration, with 0 disabled (def=2)"

                correction coefstroke="1.8" coefperiod="1" powerfunc="3" comment="Drift correction configuration (def=no applied)"


  • Please share the whole xml,


  • samsam
    edited September 18

    Sorry, I can't share the whole xml here. Can I email it to you? What else you need to know?

  • yes, you can send it by email to

Sign In or Register to comment.