Error - PosCellCode


This happens when I increase resolution by reducing initial particle distance. Is there any fix?

I have never seen this before.

Kind regards


  • I have the same issue right now.

    I tried to play with the resolution increasing and decreasing it in order to see when this happens. There is a threshold above which I get exactly this same error message.

    Increasing it further will lead at some point to a GPU memory issue (I am running my simulation on a single GPU).

    I would be keen to learn if there is a possible solution to this so that I can increase resolution - untill I hit the performance ceiling of my hardware... :D

  • Hmm, I do not understand how it can be a GPU memory error? The first line shows that it is only 325k particles who fill 52.2 MB, so there should be no issue what so ever with memory..

    But yes, the problem also occured when I increased resolution - could you share your case file where this happens and maybe the DualSPHysics team could have a look at it, @Alex ?

    Kind regards

  • We will check it when we have time, I already sent this issue to Dr José Domínguez (@jmdalonso) who can help better here


  • Hi,

    I agree that it is most likely not related to GPU memory and I did not say it was. I just said that when I tried to see if I get this error message too when setting the resolution to a much higher value I ran into GPU memory issue :)

    Well, let's see if Dr. Domínguez can help us.

Sign In or Register to comment.