Restarting a simulation

Hello,

I hope y'all are safe.

Yesterday my simulation failed with an error message that reads "Text: Overflow in reading data."

I followed the example given in examples/others/Restart as well as the suggestions given in old posts but whenever I try to restart it, I am getting the following error


In the source code,it is defined in line 1503 of JBinaryData.cpp

But I'm not sure what exactly is happening could someone please help me?

Thank you!

Comments

  • Please check first if you have space enough in your hard disk.

    Sometime this message appears when you are running out of space in disk to save output data.


    Regards

  • I just freed up some space and I'm still getting the same message.

  • Without accessing to your folders and see what happen will be diffcult to help you

    What happens when you try the example in examples/others/Restart. Please let us know if that works, otherwise there should be an error there.

    Regards 

  • Hi Alex,

    When I run it, I get the following error

    But I know that this error has something to do with the case definition, so I believe the nature of this error and overflow error are different.

  • @Asalih3d thanks but that's not the problem I know how to get rid of it. It was just a test case. The main problem is when I try to restart I am getting an error message saying "Overflow in reading data".

  • I've been playing around and one thing I notice is that if I change -partbegin: to any number other than the final step, I get a different error that says


    But whenever I use the part # that my simulation failed the message reads "overflow in reading data".

    Also, the only difference between the example/Restart and my case is that I don't generate .vtk files. In that example, it runs for 100 parts then generates .vtk files and then restarts. Maybe this explains why I'm getting "Mk block of particle was not found".

    Does it mean that DSPH solver can't read the information directly from .bi4 files? But this wouldn't make sense, it would be both cost and time inefficient.

  • I don't that't the case. I tried it after creating .vtk files but it still says "Mk block of particle was not found."

  • You should use with -partbegin the last part created in the first simulation. However this part file should not be an error... I mean that in that case you should use the last part without errors. Can you try that?

    Regards

  • I tried it and didn't get it to work. I tried it with different parts and none worked. I decided to re-run it.

  • The case as example in examples/others is working ok... so we should check your case to see what happens

  • edited October 15

    I am getting the same error reported by @circles when I try to simulate a domain with inlet/outlet boundaries. The example case located at exemples/others/Restart is working because any new particule is added ou remove from the domain. I got the same error (see below) when I run any inlet/outlet example : Flow cylinder, Open Channel 2D, Reverse Flow, Waves 2D, Shapes Inlet 3D, Current Hull, etc.

    Exception (JSphMk::GetCodebyId) at ..\source\JSphMk.cpp:165

    Text: Mk block of particles (idp=#######) was not found.

    Any idea how I could be resolve this error/exception?

    Best regards,

    PS : the version tested correspond to DualSPHysics v5.0

  • The option of Restart is not implemented yet for inlet/outlet conditions

    Regards

Sign In or Register to comment.