boundary velocity particle excluded/error

I have developed a simulation for a rotating capsule with water, pieces of plastic media, and a metal part as shown below (removed the fluid from the capsule for better visualization of the boundary particles, but the capsule if filled half way with water).


Everything works except after a certain number of generated vtk files the error below pops up. After looking at the error boundary vtk file it doesn't make much sense what is wrong because there are very few particles visible to make out what is going on.



As I decrease the particle spacing the number of vtk files that gencase can produce also increases thus nearing the completion of the simulation. This can become on issue because the memory of the folder containing vtk files can become substantially large and the processing time can take very long as well. I am not sure why this is happening so how can I resolve this issue without having to increase the resolution (decrease the particle spacing)?

Below is the last vtk file produced and proceeding it has the enhanced image of the error boundary vtk particles that have been enlarged as black spheres (8 black particles) and circled in red.

.


Comments

  • Some floating particles are leaving the domain.

    One reason can be that the collisions between the solid objects is not correct...

    You have to use CHRONO to solve collisions. CHRONO can solve collisions between boundary objects (fixed, moving or floating) and this collision is solved in terms of geometries, not in terms of particles, but you need to define:

          <parameter key="RigidAlgorithm" value="3" comment="Rigid Algorithm 1:SPH, 2:DEM, 3:Chrono (default=1)" />

    1) the geometries using VTK, STL or other that you can define with modelfile="XXXXXX" (here you can include a geo or just use the ones created with GenCase CaseDp.vtk or CaseActual.vtk using modelfile="AutoDp" or modelfile="AutoActual"

    2) reading material properties from other external XML where Chrono will use the values of friction and restitution coefficient

    3) collisiondpvalue will define the minimum distance to detect collisions, and here we decide to use as reference the value of "dp", so that collisiondpvalue="0.5" means that minimum distance for collision will be 0.5*dp

  • I am attempting to use CHRONO however I am running into some issues. The simulation that I showed you before was with DEM so I had the xml containing the material properties and already set the other parameters you suggested to use CHRONO. As you can see below I have the media along with the cylinder going straight through the capsule as well as some fluid (this simulation has a lower resolution or larger particle spacing).

    I believe the fluid is leaving the capsule (added it using a ply file) because there are some holes due to the way that the particles are placed in a Cartesian grid. As for the issue with the objects leaving the capsule I believe it is because I have to define modelfile, but I tried defining it various different ways after trying your suggestions in your last reply. Attached below is how I defined modelfile by setting it to "AutoActual" and the image following it is the error I received. I receive a similar error when I set modelfile="AutoDp".

    After that I tried to define modelfile using a geo since all of the objects in the capsule are ply files, but I was not sure how to do so and the CHRONO case files in the dualsphysics package didn't do much help for me because they only defined modelfile with AutoActual or AutoDp. What would you suggest? Also thank you for getting back to me @Alex.

  • In order to use AutoActual, yo need to create first the Case__Actual.vtk

    Those files can be created as shown in page 25 of XMLGUIDEv4.4.pdf


    Regards

Sign In or Register to comment.