File of the particles was not found

Hi,
I run the simlation with tens of million particles, then it's said :

when I set the dp larger, it works normal. But it can't work with a smaller dp.
I don't know why, does anyone meet similar situation?

Regards

Comments

  • what is the previous output message of the execution of GenCase? in Case.out?
    larger dp means less particles so the memory of your device was enough, but now you may have created too many particles so Case.bi4 was not created due to the memory space of your GPU
  • The simulation stopped at the red line


    before it stopped, Case.bi4 and other VTKs had already been generated in the Case_out file


    I didn't check whether my GPU was out of memory or not, I just thought program would tell user "Your GPU is out of memory".

    Tommorrow I will check the memory.
  • edited May 27
    @Alex
    I use the GPU-Z to check the the memory space of my GPU. I find that it's not because of GPU out of memory, it was caused by the limitation of the GPU clock and memory clock

    In the first circle, the simulation stoped at dp=8mm. In the scecond circle, the simulation worked normal at dp=8.5mm.

    the memory used didn't change much, so i think it was due to the limitation of the GPU clock and memory clock.

    so just for simulating more particles , gpu not only need more memory space but also need higher gpu clock to load the Case.bi4? What about more cores?

    Does the DualSPHysics compatible the QUADRO RTX 6000?

    Regards
  • perhaps Orlando and Jose can add here to help
    @Admin @jmdalonso ?
  • I have encountered the same problem. Any help would be highly appreciated. I'm using Tesla K80.
    @Admin @jmdalonso
  • Sorry I made the same title topic in this forum. I had the same problem.

    During simulation with fine particles, more than 100 million particles corresponding to 4-5GB of an initial state of particles file (Case.bi4) which GENCASE generated, the error following appeared, and the simulation will be stopped, even though the file exists in Case_out.

    *** Exception (JPartsLoad4::LoadParticles)
    Text: File of the particles was not found.
    File: Case_out/Case.bi4

    I think the error could be related with following functions.




    and




    I’m not familiar with state function in FileType, however, when I run simulation with a lot of particles, FileType would return the value which is not equal to 2, thus FileExists would return False value and the error, “File of the particles was not found”, occurred.

    So I modified the related code as following and I'm done with the simulation without the error.

    if(fun::FileExists(file1)+1)pd.LoadFileCase(dir,casename,0,1);

    However, Post processing tool stopped due to the same reasons above.

    It would be very appreciated if developers could modify the bug and enable us to rum simulation and Post-processing tool with a lot of particles.

    Many thanks
  • I still didn't solve it.These days, there are many posts discussed this problem, it seems that DualSPHysics4.4 simulates with more than tens of million particles would have some problem.

    Hoping for the solution!
    Chao
  • Please can you try again now with latest version DualSPHysics_v4.4.05.zip

    we have uploaded in https://dual.sphysics.org/index.php/downloads/

  • @Alex

    Thank you.


    I suspect that this might also address the problem (of the same) that I was having as well, so I'll try this out and hopefully this will work.


    Thank you.

  • @Alex

    I downloaded the latest version, and it worked well !!!

    Thanks a lot for the work of DualSPHysics team.☺️


    Best wish

    Chao

Sign In or Register to comment.